libgloss: fix AC_LANG_SOURCE warnings w/newer autoconf

Message ID 20210915044021.18138-1-vapier@gentoo.org
State Accepted
Commit 63c1f29a1d652aa5ace2bf2531d9e2fe35edf21d
Headers show
Series
  • libgloss: fix AC_LANG_SOURCE warnings w/newer autoconf
Related show

Commit Message

Mike Frysinger Sept. 15, 2021, 4:40 a.m.
When running autoconf-2.69 in here, we get:
configure.ac:57: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2503: _AC_PREPROC_IFELSE is expanded from...
../../lib/autoconf/general.m4:2518: AC_PREPROC_IFELSE is expanded from...
configure.ac:57: the top level
configure.ac:61: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2503: _AC_PREPROC_IFELSE is expanded from...
../../lib/autoconf/general.m4:2518: AC_PREPROC_IFELSE is expanded from...
configure.ac:61: the top level

Add AC_LANG_PROGRAM wrappings to fix these.
---
 libgloss/csky/configure.ac | 8 ++++----
 libgloss/m68k/configure.ac | 8 ++++----
 2 files changed, 8 insertions(+), 8 deletions(-)

-- 
2.33.0

Comments

Corinna Vinschen Sept. 15, 2021, 8:42 a.m. | #1
On Sep 15 00:40, Mike Frysinger wrote:
> When running autoconf-2.69 in here, we get:

> configure.ac:57: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body

> ../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...

> ../../lib/autoconf/general.m4:2503: _AC_PREPROC_IFELSE is expanded from...

> ../../lib/autoconf/general.m4:2518: AC_PREPROC_IFELSE is expanded from...

> configure.ac:57: the top level

> configure.ac:61: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body

> ../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...

> ../../lib/autoconf/general.m4:2503: _AC_PREPROC_IFELSE is expanded from...

> ../../lib/autoconf/general.m4:2518: AC_PREPROC_IFELSE is expanded from...

> configure.ac:61: the top level

> 

> Add AC_LANG_PROGRAM wrappings to fix these.


LGTM.  Feel free to push all 4 patches:

  libgloss: fix AC_LANG_SOURCE warnings w/newer autoconf           
  libgloss: epiphany: rename symbol prefix cache var
  libgloss: add missing aclocal.m4 files
  newlib: sig2str: use __restrict


Thanks,
Corinna

Patch

diff --git a/libgloss/csky/configure.ac b/libgloss/csky/configure.ac
index e24bd7d13a34..4b0baaeee6ee 100644
--- a/libgloss/csky/configure.ac
+++ b/libgloss/csky/configure.ac
@@ -54,13 +54,13 @@  dnl an executable or not.
 dnl
 saved_LDFLAGS="$LDFLAGS"
 LDFLAGS="-nostdlib -e main"
-AC_PREPROC_IFELSE([#ifndef __mcoldfire__
+AC_PREPROC_IFELSE([AC_LANG_PROGRAM([#ifndef __mcoldfire__
 		#error we are not coldfire
-		#endif],
+		#endif])],
 	       DO="cf",)
-AC_PREPROC_IFELSE([#ifndef __mfido__
+AC_PREPROC_IFELSE([AC_LANG_PROGRAM([#ifndef __mfido__
 		#error we are not fido
-		#endif],
+		#endif])],
 	       DO="fido",)
 LDFLAGS=$saved_LDFLAGS
 AC_MSG_RESULT($DO)
diff --git a/libgloss/m68k/configure.ac b/libgloss/m68k/configure.ac
index 0ec58609182a..34ea86a7328c 100644
--- a/libgloss/m68k/configure.ac
+++ b/libgloss/m68k/configure.ac
@@ -54,13 +54,13 @@  dnl an executable or not.
 dnl
 saved_LDFLAGS="$LDFLAGS"
 LDFLAGS="-nostdlib -e main"
-AC_PREPROC_IFELSE([#ifndef __mcoldfire__
+AC_PREPROC_IFELSE([AC_LANG_PROGRAM([#ifndef __mcoldfire__
 		#error we are not coldfire
-		#endif],
+		#endif])],
 	       DO="cf",)
-AC_PREPROC_IFELSE([#ifndef __mfido__
+AC_PREPROC_IFELSE([AC_LANG_PROGRAM([#ifndef __mfido__
 		#error we are not fido
-		#endif],
+		#endif])],
 	       DO="fido",)
 LDFLAGS=$saved_LDFLAGS
 AC_MSG_RESULT($DO)