Use Linux 5.11 in build-many-glibcs.py

Message ID alpine.DEB.2.22.394.2102152258330.3093992@digraph.polyomino.org.uk
State Superseded
Headers show
Series
  • Use Linux 5.11 in build-many-glibcs.py
Related show

Commit Message

Joseph Myers Feb. 15, 2021, 10:58 p.m.
This patch makes build-many-glibcs.py use Linux 5.11.

Tested with build-many-glibcs.py (host-libraries, compilers and glibcs
builds).


-- 
Joseph S. Myers
joseph@codesourcery.com

Comments

Noah Goldstein via Libc-alpha Feb. 22, 2021, 4:07 p.m. | #1
* Joseph Myers:

> This patch makes build-many-glibcs.py use Linux 5.11.

>

> Tested with build-many-glibcs.py (host-libraries, compilers and glibcs

> builds).

>

> diff --git a/scripts/build-many-glibcs.py b/scripts/build-many-glibcs.py

> index 071f338cbb..d7b66d6b14 100755

> --- a/scripts/build-many-glibcs.py

> +++ b/scripts/build-many-glibcs.py

> @@ -769,7 +769,7 @@ class Context(object):

>                              'gcc': 'vcs-10',

>                              'glibc': 'vcs-mainline',

>                              'gmp': '6.2.1',

> -                            'linux': '5.10',

> +                            'linux': '5.11',

>                              'mpc': '1.2.1',

>                              'mpfr': '4.1.0',

>                              'mig': 'vcs-mainline',


I did a full bootstrap with this and didn't see any issue.  Looks good
to me.

Thanks,
Florian

Patch

diff --git a/scripts/build-many-glibcs.py b/scripts/build-many-glibcs.py
index 071f338cbb..d7b66d6b14 100755
--- a/scripts/build-many-glibcs.py
+++ b/scripts/build-many-glibcs.py
@@ -769,7 +769,7 @@  class Context(object):
                             'gcc': 'vcs-10',
                             'glibc': 'vcs-mainline',
                             'gmp': '6.2.1',
-                            'linux': '5.10',
+                            'linux': '5.11',
                             'mpc': '1.2.1',
                             'mpfr': '4.1.0',
                             'mig': 'vcs-mainline',