[pushed] testsuite, Objective-C : Update a test for newer OS versions.

Message ID 57BA28D0-8CFD-4DA8-8373-5B7D5E5CD74A@sandoe.co.uk
State New
Headers show
Series
  • [pushed] testsuite, Objective-C : Update a test for newer OS versions.
Related show

Commit Message

Iain Sandoe Oct. 11, 2020, 1:55 p.m.
Hi

Objective-C GC is not available for any recent Darwin version, nor
is it available for the upcoming release of Darwin20.  This just updates
the skip conditions for the test.

tested across the Darwin range, and on x86_64-linux
pushed to master
thanks
Iain

gcc/testsuite/ChangeLog:

	* objc.dg/objc-gc-4.m: Disable for macOS 10.15 and 11.x.
---
 gcc/testsuite/objc.dg/objc-gc-4.m | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

-- 
2.24.1

Patch

diff --git a/gcc/testsuite/objc.dg/objc-gc-4.m b/gcc/testsuite/objc.dg/objc-gc-4.m
index 96c32788dfe..8102a5a532f 100644
--- a/gcc/testsuite/objc.dg/objc-gc-4.m
+++ b/gcc/testsuite/objc.dg/objc-gc-4.m
@@ -3,7 +3,7 @@ 
 /* Contributed by Ziemowit Laski <zlaski@apple.com>  */
 
 /* { dg-do compile } */
-/* { dg-skip-if "GC API is an error from Darwin16." { *-*-darwin1[6-8]* } { "-fnext-runtime" } { "" } } */
+/* { dg-skip-if "GC API is an error from Darwin16." { *-*-darwin1[6-9]* *-*-darwin2[0-9]* } { "-fnext-runtime" } { "" } } */
 /* { dg-options "-fobjc-gc" } */
 /* { dg-prune-output "cc1obj: warning: '-fobjc-gc' is ignored for '-fgnu-runtime'" } */