[pushed] update-gnulib.sh: Report required versions of autoconf/aclocal

Message ID 20180614224000.17174-1-simon.marchi@polymtl.ca
State New
Headers show
Series
  • [pushed] update-gnulib.sh: Report required versions of autoconf/aclocal
Related show

Commit Message

Simon Marchi June 14, 2018, 10:40 p.m.
Update the messages printed when the wrong version of autoconf/aclocal
is found to include the expected version too, like we already do for
automake.

gdb/ChangeLog:

	* gnulib/update-gnulib.sh: Print expected versions of
	autoconf/aclocal.
---
 gdb/ChangeLog               | 5 +++++
 gdb/gnulib/update-gnulib.sh | 6 ++++--
 2 files changed, 9 insertions(+), 2 deletions(-)

-- 
2.17.1

Patch

diff --git a/gdb/ChangeLog b/gdb/ChangeLog
index aba9a1a1b1f3..6e1e9048ca5d 100644
--- a/gdb/ChangeLog
+++ b/gdb/ChangeLog
@@ -1,3 +1,8 @@ 
+2018-06-14  Simon Marchi  <simon.marchi@polymtl.ca>
+
+	* gnulib/update-gnulib.sh: Print expected versions of
+	autoconf/aclocal.
+
 2018-06-14  Simon Marchi  <simon.marchi@ericsson.com>
 
 	* arch-utils.c (default_type_align): Use type_length_units.
diff --git a/gdb/gnulib/update-gnulib.sh b/gdb/gnulib/update-gnulib.sh
index 74ccfb0e18e2..70c23e80c05e 100755
--- a/gdb/gnulib/update-gnulib.sh
+++ b/gdb/gnulib/update-gnulib.sh
@@ -107,7 +107,8 @@  fi
 # Verify that we have the correct version of autoconf.
 ver=`autoconf --version 2>&1 | head -1 | sed 's/.*) //'`
 if [ "$ver" != "$AUTOCONF_VERSION" ]; then
-   echo "Error: Wrong autoconf version: $ver. Aborting."
+   echo "Error: Wrong autoconf version ($ver), we need $AUTOCONF_VERSION."
+   echo "Aborting."
    exit 1
 fi
 
@@ -138,7 +139,8 @@  fi
 #
 ver=`aclocal --version 2>&1 | grep -v "called too early to check prototype" | head -1 | sed 's/.*) //'`
 if [ "$ver" != "$ACLOCAL_VERSION" ]; then
-   echo "Error: Wrong aclocal version: $ver. Aborting."
+   echo "Error: Wrong aclocal version ($ver), we need $ACLOCAL_VERSION."
+   echo "Aborting."
    exit 1
 fi