sim: require AC_PROG_CPP explicitly

Message ID 20210222043829.10893-1-vapier@gentoo.org
State New
Headers show
Series
  • sim: require AC_PROG_CPP explicitly
Related show

Commit Message

Simon Marchi via Gdb-patches Feb. 22, 2021, 4:38 a.m.
All the scripts were using this implicitly already, so there's no real
change for them, but we want to call it explicitly as the CPP tool is
used to generate nltvals.def.
---
 sim/m4/sim_ac_common.m4 | 1 +
 1 file changed, 1 insertion(+)

-- 
2.30.0

Patch

diff --git a/sim/m4/sim_ac_common.m4 b/sim/m4/sim_ac_common.m4
index bfbde3fe1bf9..32d7f14c96a4 100644
--- a/sim/m4/sim_ac_common.m4
+++ b/sim/m4/sim_ac_common.m4
@@ -22,6 +22,7 @@  dnl See README-HACKING for more details.
 AC_DEFUN([SIM_AC_COMMON],
 [
 AC_REQUIRE([AC_PROG_CC])
+AC_REQUIRE([AC_PROG_CPP])
 AC_CONFIG_HEADERS([config.h:config.in])
 AC_CANONICAL_SYSTEM
 AC_USE_SYSTEM_EXTENSIONS