[committed] Darwin, testsuite: Fix darwin-version-1.c fails with XCode 11.4.

Message ID 16BEBA92-775C-48D7-B217-696329133B3F@sandoe.co.uk
State New
Headers show
Series
  • [committed] Darwin, testsuite: Fix darwin-version-1.c fails with XCode 11.4.
Related show

Commit Message

Iain Sandoe April 13, 2020, 6:32 p.m.
Hi,

From XCode 11.4 on 10.14/15 use of 10.6 and 10.7 is deprecated.
The tools issue diagnostics if -mmacosx-version-min= < 10.8

Adjust the testcase to avoid that usage on 10.14, 10.15 for now.

tested on x86_64-darwin10, 19
applied to master
thanks
Iain

gcc/testsuite/ChangeLog:

2020-04-13  Iain Sandoe  <iain@sandoe.co.uk>

	* gcc.dg/darwin-version-1.c: Use -mmacosx-version-min= 10.8
	for system versions 10.14 and 10.15.

Patch

diff --git a/gcc/testsuite/gcc.dg/darwin-version-1.c b/gcc/testsuite/gcc.dg/darwin-version-1.c
index ad7f7da3b63..2ca34c6c007 100644
--- a/gcc/testsuite/gcc.dg/darwin-version-1.c
+++ b/gcc/testsuite/gcc.dg/darwin-version-1.c
@@ -5,7 +5,9 @@ 
 /* Later Darwin linkers decline to link for less than Darwin8/MacOS 10.4.
    However, we need to make the link for 10.6 because the relevant libgcc_s
    shim files for 10.4 and 10.5 are also not installed in later SDKs.  */
-/* { dg-options "-mmacosx-version-min=10.6" { target *-*-darwin[123]* } } */
+/* { dg-options "-mmacosx-version-min=10.6" { target *-*-darwin1[01234567]* } } */
+/* From XCode 11.4 on 10.14/15 10.6 and 10.7 are also deprecated.  */
+/* { dg-options "-mmacosx-version-min=10.8" { target *-*-darwin1[89]* } } */
 /* { dg-do link { target *-*-darwin* } } */
 
 int main()