Use Linux 5.6 and GMP 6.2.0 in build-many-glibcs.py [committed]

Message ID alpine.DEB.2.21.2003310022410.1671@digraph.polyomino.org.uk
State New
Headers show
Series
  • Use Linux 5.6 and GMP 6.2.0 in build-many-glibcs.py [committed]
Related show

Commit Message

Joseph Myers March 31, 2020, 12:22 a.m.
This patch makes build-many-glibcs.py use the current versions of
Linux (5.6) and GMP (6.2.0).

Tested with build-many-glibcs.py (host-libraries, compilers and glibcs
builds).


-- 
Joseph S. Myers
joseph@codesourcery.com

Patch

diff --git a/scripts/build-many-glibcs.py b/scripts/build-many-glibcs.py
index 24271a7d8b..4832912b28 100755
--- a/scripts/build-many-glibcs.py
+++ b/scripts/build-many-glibcs.py
@@ -749,8 +749,8 @@  class Context(object):
         default_versions = {'binutils': 'vcs-2.34',
                             'gcc': 'vcs-9',
                             'glibc': 'vcs-mainline',
-                            'gmp': '6.1.2',
-                            'linux': '5.5',
+                            'gmp': '6.2.0',
+                            'linux': '5.6',
                             'mpc': '1.1.0',
                             'mpfr': '4.0.2',
                             'mig': 'vcs-mainline',