[committed] Darwin, libsanitizer: Update minimum supported system version.

Message ID CC1BF925-8437-421D-B018-C1CB80ED6A43@sandoe.co.uk
State New
Headers show
Series
  • [committed] Darwin, libsanitizer: Update minimum supported system version.
Related show

Commit Message

Iain Sandoe March 3, 2020, 11:53 a.m.
Hi,

The imported sources from 'upstream’ on the 9 branch do not
support Darwin10 or earlier, so do not enable these by default.

tested on x86_64-darwin and linux,
applied to the branch
thanks
Iain

libsanitizer/ChangeLog:

2020-03-03  Iain Sandoe  <iain@sandoe.co.uk>

	* configure.tgt (x86_64-*-darwin*, i?86-*-darwin*): Enable by
	default only for Darwin versions greater than equal to 11
	(macOS 10.7).

Patch

diff --git a/libsanitizer/configure.tgt b/libsanitizer/configure.tgt
index b241ddbfec4..424fb17a45c 100644
--- a/libsanitizer/configure.tgt
+++ b/libsanitizer/configure.tgt
@@ -60,7 +60,7 @@  case "${target}" in
 		TSAN_TARGET_DEPENDENT_OBJECTS=tsan_rtl_aarch64.lo
 	fi
 	;;
-  x86_64-*-darwin[1]* | i?86-*-darwin[1]*)
+  x86_64-*-darwin1[1-9]* | i?86-*-darwin1[1-9]*)
 	TSAN_SUPPORTED=no
 	;;
   x86_64-*-solaris2.11* | i?86-*-solaris2.11*)